An abnormal message in apps manager UI, "The scheduler service has not been enabled yet"
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An abnormal message in apps manager UI, "The scheduler service has not been enabled yet"

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Article ID: 384921

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Updated On:

Products

VMware Tanzu Application Service

Issue/Introduction

When reviewing the jobs configuration in apps manager UI, you might find an abnormal message, "The scheduler service has not been enabled yet".

Cause

This happens when duplicated scheduler service instances are created in a single space. As stated in the document: The Scheduler service is a singleton service. Only one service instance can be created in a space.

You may notice the following error message in the broker log, "Provision Handler:Duplicate In Space". The broker log can be found through "cf logs scheduler --recent" in org system / space scheduler.

"caller":"handlers/provision.go:50","msg":"Provision Handler:Duplicate In Space","stacktrace":"pcf-scheduler/broker/web/handlers.ProvisionHandler.ServeHTTP

    /var/vcap/data/compile/broker/pcf-scheduler/broker/web/handlers/provision.go:50

pcf-scheduler/broker/web/middleware.BasicAuthenticationHandler.HandleBasicAuth-fm.BasicAuthenticationHandler.HandleBasicAuth.func1

Resolution

  • Find out all scheduler service instances in the current space and their GUIDs

    • cf services
    • cf service <scheduler service instance name> --guid
  • Keep the oldest scheduler service instance and remove all others with commands below.

         a) Get the creation time of each scheduler service instance

      • cf curl /v2/service_instances/<service_instance_guid> | jq '.metadata.created_at'

         b) Remove all other scheduler service instances except the oldest one

      • cf delete-service <any_not-the-oldest_scheduler_service_instance_name>
  • Refresh the Apps manager UI.