ESXi Host not compatible with attached Host Profile due to SSH authorized key value mismatch
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ESXi Host not compatible with attached Host Profile due to SSH authorized key value mismatch

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Article ID: 384892

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Updated On:

Products

VMware vSphere ESXi VMware vSphere ESXi 6.0 VMware vSphere ESXi 7.0 VMware vSphere ESXi 8.0

Issue/Introduction

ESXi Host may not be compatible with Host Profile attached to it if SSH authorized key for the user root is either missing or has a different value

Environment

vSphere ESXi 6.x
vSphere ESXi 7.x
vSphere ESXi 8.x

Cause

SSH key are added for the user account in ESXi Host which is either not present in Host Profile or has a different value resulting in Host not being complaint with the attached profile

Resolution

To resolve the issue, add the authorized SSH key for the user root in the host profile attached to the Host if this is a requirement or if Zerto is being used

Else remove the key from ESXi host from authorized_keys files by following steps mentioned here:

1. SSH to the ESXi Host
2. Backup the file using cp /etc/ssh/keys-root/authorized_keys /etc/ssh/keys-root/authorized_keys.bak
3. Clear contents of the file using the command: echo "" /etc/ssh/keys-root/authorized_keys

Note, The key can be found on the ESXi host at location /etc/ssh/keys-root/authorized_keys

Additional Information

Zerto VRA will fail to install with message: "SSH authorized key for root user has been modified"

Resolution is same as mentioned above and more info can be found here: https://help.zerto.com/kb/000004727