Users installed DE Webclient and the service runs. Then, the service(CA_Workload_Automation_DE_WebClient) disappears from services.msc for some reason.
Environment
CA Workload Automation DSeries: 12.x
Cause
Services suddenly disappearing is typically related to some kind of Security application (aka: anti malware, virus, etc).
Resolution
Work with the Security tools teams to address this problem.
Additional Information
One way to go about doing this is to:
Inventory of all security tools installed on this system. It is not uncommon for there to be more than one security tool installed.
Once all security tools have been identified, host a meeting with the teams responsible for those tools. Explain the situation.
The security admins might see something on their end that they can try immediately.
Plan to temporarily disable one service at a time, install the WebClient, let it run for a period of time to see if the Service disappears.
If it disappears, you know it's not being caused by the tool that's been disabled.
Rinse and repeat until you have disabled the tool and find confirmed the Service does not disappear anymore. Once you've done that you've found the problematic software and you'll need to work further with that security team to define an appropriate exception.