Multiple emails were registered under a domain in Email Security.cloud
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Multiple emails were registered under a domain in Email Security.cloud

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Article ID: 384857

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Updated On:

Products

Email Security.cloud

Issue/Introduction

The article describes the following scenario:

Hundreds of emails were registered under a domain. There are two points to consider:

1. How to delete these emails?

2. Is there any possibility to check which account was responsible for registering these emails?

Environment

Email security.cloud

Cause

The number of users emails has increased due to Automatic outbound harvesting feature used by ESS service design.

More information about the technology is under:

Automatic outbound harvesting feature

This is a normal behavior of the service. Email Security.cloud harvests all email addresses that send mail outbound by your registered outbound IP addresses. These addresses are automatically added to the list of registered addresses.

Harvest is discovering and AUTO-UPDATING a new entry under address registration.

Resolution

The end client can delete manually the users but this is against how service is design to work.

The emails are from the legit senders of the domain. They were not added before but Email security cloud added them automatically based on Outbound harvesting feature.