Webservices in Service Desk Manager Are Not Working after Copying Installation
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Webservices in Service Desk Manager Are Not Working after Copying Installation

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Article ID: 384815

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Updated On:

Products

CA Service Management - Service Desk Manager CA Service Catalog CA Process Automation Base

Issue/Introduction

After copying a production environment to a new machine, integrations between Service Desk Manager, Service Catalog, and IT Process Automation are not working.

All products accept authentication and allow access via the GUI, but processes configured between the products are not working.

The original production environment is not encountering the same issue

When testing Web Services by navigating to <FQDN>:<port>/axis/services/USD_R11_WebService generates:

AXIS error

No service is available at this URL

Redeploying Web Services using this KB:

Redeploy Web Services

Did not resolve the error. 

Environment

All versions of Service Desk Manager, Service Catalog, and IT Process Automation Manager

Cause

Missing and/or corrupted files within the Tomcat webapps folder (C:\Program Files (NX_ROOT\bopcfg\www\CATALINA_BASE\webapps)  caused this issue.

Resolution

Customer took the NX_ROOT\bopcfg\www\CATALINA_BASE\webapps folder from a working environment and copied this folder to the affected environment.

This resolved the issue, but it is strongly believed that the issue originated while copying the original environment.

We will link the proper copying procedures in the Additional Information section of this KB

Additional Information