unable to start SDM via pdm_init as srvcdesk user
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unable to start SDM via pdm_init as srvcdesk user

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Article ID: 384718

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Updated On:

Products

CA Service Management - Service Desk Manager CA Service Desk Manager

Issue/Introduction

After upgrading to SDM 17.4 RU3, the pdm_init cannot be started as the Privileged User “srvcdesk”.

The NX_ROOT/log/pdm_tomcat.log contains these two lines:

Error: Could not find or load main class org.apache.catalina.startup.Bootstrap

Caused by: java.lang.ClassNotFoundException: org.apache.catalina.startup.Bootstrap

pdm_init works OK when running as root.

Environment

SDM 17.4 RU3 on RHEL 8.6

Cause


When Tomcat tries to start, it runs a command and one of the files called is <installation folder>/SC/tomcat/9.0.86/bin/bootstrap.jar. This jar file has the org.apache.catalina.startup.Bootstrap class.

srvcdesk user does not have proper permissions to read/write/execute one of the files being used to start SDM services

Resolution

Assign srvcdesk user proper permissions to read/write/execute <installation folder>/SC/tomcat/9.0.86/bin/bootstrap.jar file. 

Refer to the following link for the steps on how to manage permissions in Linux environments: How to manage Linux permissions for users, groups, and others