Operator Console (OC) session expired even though user is actively working
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Operator Console (OC) session expired even though user is actively working

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Article ID: 384707

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Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM)

Issue/Introduction

While actively working in OC 24.3CU2, as administrator, I'm kicked out from OC with the message below:

Session expired | Your current session is expired. Click on the below link to re-login. | Return to Operator console 

As per: Operator Console OC timeout settings in DX UIM 20.x and 23.4 versions

I have set the following parameters in the wasp.cfg:

oc.jwt.expiryInSecs = 3600
oc.jwt.refreshInterval = 900

This implies that the session should expire 1 hour after the login, unless I'm actively working in OC, in which case the authorization token should be refreshed to avoid being kicked out from the session. 

However, no matter if the user is active, after 1 hour (3600 secs), the session expires. 

Why is this happening?

Environment

DX UIM 23.4.*

Cause

Known Defect: when the wasp.cfg key ump.disallow.simultaneous.logins is equal to true the authorization token refresh does not occur. 

The ump.disallow.simultaneous.logins wasp key can disallow multiple sessions per user. When you log in for a second time, a pop up appears. 

Documented here: Restrict Multiple Simultaneous Logins in Operator Console

When this option is active, the user session (defined in oc.jwt.expiryInSecs) ends even though the user is active as the authorization token is not refreshed. 

Resolution

This issue will be fixed in a future release. 

As a workaround, set ump.disallow.simultaneous.logins = false to avoid session expires even though the user is active.