Stuck tasks -- "Recompute Datastore Groups" and "Recompute Device Groups" in vSphere Client
book
Article ID: 384687
calendar_today
Updated On:
Products
VMware Live Recovery
Issue/Introduction
vSphere Client reports stuck tasks 'Recompute Datastore Groups' and 'Recompute Device Groups' in the environment where Site Recovery Manager is configured with Array-Based Replication (SRA)
++ Unable to cancel the tasks nor it times out. ++ Running 'Discover Devices' in Site Recovery UI (Under Configure > Array Based Replication > Array Pairs), triggers these two tasks and completes successfully. ++ Old tasks still remains in vSphere Client.
Environment
Vmware Site Recovery Manager 8.x Vmware Live Site Recovery 9.x
Cause
This is usually seen if SRM appliances were rebooted as part of upgrade or any maintenance activity which leaves the tasks stuck in vSphere Client and never executes completely as they go stale.
Resolution
a) Validate that new tasks are completing successfully. b) Check if any recent reboot of SRM servers been performed and match them with the start time of the running tasks. c) Restart vpxd and vsphere-ui services on vCenter. d) If issue still persist, reboot VCSA.