UI becomes inaccessible when upgrading Aria Operations for Logs
search cancel

UI becomes inaccessible when upgrading Aria Operations for Logs

book

Article ID: 384648

calendar_today

Updated On:

Products

VCF Operations/Automation (formerly VMware Aria Suite)

Issue/Introduction

During the upgrade process, the user interface can become inaccessible, and the Cassandra services on Aria Ops for Logs nodes are periodically restarting.

Environment

Aria Operations for Logs 8.X

Cause

Issues with communication to the peers due to SSL handshake issues which resulted in Cassandra restarting intermittently on the nodes which caused Aria Operations to Logs.

Resolution

  1. Revert snapshots before trying to attempt the upgrade.
  2. Reset to default certs via the user interface in Aria Operations for logs. Go to Administration >> SSL, then reset to default certs
  3. Apply Upgrade in Aria Operations for Logs, use  as reference: Upgrading VMware Aria Operations for Logs
  4. Re-apply Aria Operations for Logs custom certs. Install a Custom SSL Certificate

Note If you are using Aria Lifecycle, synchronize the changes done in Aria Operations for logs and re-apply the custom certs certs

Additional Information

Updating the instance manually from the CLI may be a better option if UI is unavailable for other reasons. Please use the steps from KB below: 

Manually Upgrade Aria Operations for Logs