NSX Manager UI inventory missing or not loading
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NSX Manager UI inventory missing or not loading

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Article ID: 384553

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Updated On:

Products

VMware NSX

Issue/Introduction

  • NSX UI does not load for System>Fabric>Hosts or Edges, T0 gateways, T1 gateways, or Home tab.
  • An error is shown in NSX UI:
    Error: Search index is out of sync. Run the 'start search resync all' CLI command on the NSX appliance to resync. If the issue persists, contact VMware Support. INDEXING_FAILURES_EXHAUSTED_RETRIES, params: [all] (Error code: 60516)
  • Log lines similar to the below are encountered in /var/log/search/search-manager.log
    ERROR UfoIndexer-BatchExecutor-search_policy-2 UfoGenericConverter #### - [nsx@#### comp="nsx-manager" errorCode="MP60511" level="ERROR" subcomp="manager"] [Indexing: DataProvider] Could not convert UFO object to Dto UfoObject{operationType=CREATE, descriptor=IndexingTypeDescriptor{tableName='HostTransportNode', streamTag=POLICY}, identifier=string_id: "/infra/sites/default/enforcement-points/default/host-transport-nodes/esxi##-#-########-####-####-####-############host-#######"

Environment

VMware NSX

Cause

If a communication error occurs between the NSX Manager and ESXi Transport Node during an uninstallation from NSX. This will keep the ESXi Transport Node in a marked_for_delete=true state in Corfu, which causes search indexing to return an error.

Resolution

This is a condition that may occur in a VMware NSX environment.

 

Workaround:

  1. Force delete the ESXi Transport Node via API call:
    • Either using the path from the above error log: DELETE /policy/api/v1/infra/sites/default/enforcement-points/default/host-transport-nodes/esxi##-#-########-####-####-####-############host-#######?force=true
    • Or using the path actual ESXi Transport Node UUID: DELETE /api/v1/transport-nodes/########-####-####-####-############?force=true