XOG-2022: The timesheet you are uploading has time logged against the task  under project XXXX
search cancel

XOG-2022: The timesheet you are uploading has time logged against the task  under project XXXX

book

Article ID: 384532

calendar_today

Updated On:

Products

Clarity PPM On Premise Clarity PPM SaaS

Issue/Introduction

When using XOG to update a timesheet timeentry with timeperiod XOG, an error is thrown:

XOG-2022: The timesheet you are uploading has time logged against the task  under project <project id> ((<task id>))

Environment

Clarity 15.x, 16.1.x, 16.2.x, 16.3.0, 16.3.1

Cause

  • DE157504 will address the error message not being comprehensive
  • The true root cause is that taskID in the input XOG file does not match the taskID on the specified Project

Resolution

  • The error thrown is not comprehensive (error fixed with DE157504)
  • The cause is that taskID in the input XOG file does not match the taskID on the specified Project

DE157504

  • Fixed in 16.3.2
  • Starting 16.3.2, the error thrown will be:
  • XOG-2024=This task does not exist in the system. Either enter the time online, retrieve the same timesheet again and re-enter your time, or delete that task from your timesheet and upload again.

Note: The fix for DE157504 will ONLY address the error message not corresponding to the actual issue. You will still have to follow the resolution below on all Supported Clarity versions, regardless whether you get error XOG-2022 or XOG-2024

Resolution:

  • To resolve this, check Task ID on the Task and set it accordingly, then run the XOG again
  • You can also use the field externalID in PRTASK table to confirm the value
  • The solution is applicable to All Supported Releases

Additional Information