NIS Bridge unable to start due to UIM domain of 'none'
search cancel

NIS Bridge unable to start due to UIM domain of 'none'

book

Article ID: 384511

calendar_today

Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM) CA Unified Infrastructure Management On-Premise (Nimsoft / UIM) CA Unified Infrastructure Management SaaS (Nimsoft / UIM)

Issue/Introduction

nas NiS Bridge is unable to start

Environment

  • DX UIM 23.4.0
  • hub 7.80
  • robot 9.31

Cause

  • Hub/robot isconfiguration

Resolution

  1. First we had to delete the secondary hub from the IM tht was showing up as a duplicate with a domain of 'none'

  2. Then we cleared the niscache and reset the robot device id on both the Primary and the Secondary hub using the probe utility in Expert mode.

  3. Checked to make sure that the UIM domain is correct and defined correctly in all of the local hub.cfg's.

    • domain = <correctDomain>

    • not domain = <empty_value> or 'none'

  4. Checked it is set in the hub.cfg <hub> sections and the robot.cfg and click Apply/Ok to restart it.

  5. Afterwards, using IM Tools->Connect we checked the robot and we were then able to get the robot info.

  6. On the secondary hub nas using Raw configure mode, under the setup section, set:

    • nis_bridge = no

  7. Then we deactivated the nas.

  8. Waited until the port and PID disappeared.

  9. Then activated the nas and checked the nas.log to see if the nas started up or was still showing unable to start in the nas.log.

  10. Once started, select any/all probes that display as red and show a grey badge on the icon.

  11. Select the probe(s) and choose Security->Validate and choose 'Yes to all' to re-validate probe security.