Gateway Published APIs are not being Synced with Portal
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Gateway Published APIs are not being Synced with Portal

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Article ID: 384479

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Updated On:

Products

CA API Developer Portal

Issue/Introduction

In some cases when the Gateway Published APIs count goes more than 800, the gateway is unable to sync with portal.

Environment

All Supported API Developer Portal versions.

Cause

PAPI Settings >> "FEATURE_FLAG_REQUEST_XSS_FILTER" set to true causes this issue. This is limitation of this Setting.

Resolution

Increase the request size limit to 400KB by following below steps.

Check if ANTISAMY_FILTER_POLICY  is present in portal.conf

if it is then extract that to an xml file (as given in the techdocs) and update and replace in portal.conf

<directive name="maxInputSize" value="200000"/>

to

<directive name="maxInputSize" value="400000"/>

If it is not present then zip the attached config.xml and follow the steps in techdocs

https://techdocs.broadcom.com/us/en/ca-enterprise-software/layer7-api-management/api-developer-portal/5-3/set-up-and-maintenance/configure-security.html#:~:text=Custom%20Policy%20Configurations%20with%20AntiSamy