Alert Not Triggered for Budget Policy
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Alert Not Triggered for Budget Policy

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Article ID: 384362

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Updated On:

Products

CloudHealth

Issue/Introduction

The customer did not receive alert notifications for specific blocks within a policy for several accounts, despite those blocks exceeding the specified condition i.e. actual cost surpassed the allocated budget.

Environment

The policy is created for sandbox accounts with budget type - AWS categorized.
The alert is configured to trigger when accounts exceed 100% of the Month-to-Date (MTD) budget. Although the mentioned accounts surpassed this threshold, the alert did not activate as expected.

Cause

For categorized budgets, it is essential to include filters, such as the owner ID to ensure that conditions are evaluated accurately.

The issue occurred because in the condition section for the budget policy, some blocks included an owner ID while others did not. Alerts were triggered only for the accounts where the owner ID was specified.


Condition when alert fired (owner id is mentioned) -





Condition when alert did not fire (no mention of owner id in condition) -

Resolution

  1. It is mandatory to include the owner ID in the condition section.
  2. Additionally, please ensure that the block is in an enabled state for the alert to evaluate the condition.
  3. While the block is enabled by default, in some cases, customers may disable it inadvertently, unaware that this will prevent the alert from checking the condition.