When attempting to configure Cloud Director log provider, getting the error message "Protocol not available (connect failed)"
search cancel

When attempting to configure Cloud Director log provider, getting the error message "Protocol not available (connect failed)"

book

Article ID: 384320

calendar_today

Updated On:

Products

VMware Aria Suite

Issue/Introduction

When attempting to connect Cloud Director 10.6.1 to Aria Operations for Logs 8.18.2 the following error message is displayed in red at the top of the UI after failing an attempt to configure the log provider:


[ bda42a33-6bbc-4c3f-c680-e3a3204836d7 ] Cannot authenticate to log provider 'https://###.###.###.###:9543'. - I/O error on POST request for "https://###.###.###.###:9543/api/v2/sessions": Protocol not available (connect failed); nested exception is java.net.SocketException: Protocol not available (connect failed)

Environment

Cloud Director 10.6.1

Aria Operations for Logs 8.18.2

Cause

This is caused by attempting to connect to Aria Operations as opposed to Aria Operations for Logs.

Resolution

Use Aria Operations for Logs URL.