Orchestrator vCenter plugin issue SDK in bad health errors
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Orchestrator vCenter plugin issue SDK in bad health errors

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Article ID: 384246

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Updated On:

Products

VMware Aria Suite

Issue/Introduction

  • You are unable to expand the plugin inventory of a vCenter service instance on the orchestrator client.
  • Workflows and actions querying the vCenter instance for objects return no results.
  • The vco-server-app.log located under /services-logs/prelude/vco-app/file-logs/vco-server-app.log contains SDK in bad health errors similar to:

    2024-12-13T02:29:51.344Z WARN vco [host='vco-app-' thread='taskScheduler-5' user='' org='' trace=''] {} com.vmware.o11n.plugin.vsphere.connect.SessionWrapper - session <Username>@<vCenter FQDN> SDK in bad health: java.lang.RuntimeException: java.lang.reflect.InvocationTargetException

Environment

Aria Automation Orchestrator 8.18.x

Cause

The issue occurs due to a defect in the plugin

Resolution

To resolve the issue update the vCenter plugin to version 8.1.4+24375516 attached to this article.

 Steps to update the VC plugin : 

1. Download the plug-in file to your local machine. The preferred file format for Automation Orchestrator plug-ins is .vmoapp. .dar files are also supported.
2. In Automation Orchestrator, select the System Settings.
3. On the Plug-ins card, click Open.
4. Click Add Plug-in.
5. In the General pane, click Select and add the plug-in file.
6. Select a log level.
7. Click Next.
8. Review the plug-in information, if applicable, accept the end-user license agreement, and click Install.
9. Click Upload.

The plug-in is installed or updated and the Automation Orchestrator server service is restarted.

Attachments

o11n-plugin-vsphere-8.1.4+24375516.vmoapp get_app