Orchestrator vSphere vCenter Server endpoint plugin issue SDK in bad health errors
search cancel

Orchestrator vSphere vCenter Server endpoint plugin issue SDK in bad health errors

book

Article ID: 384246

calendar_today

Updated On: 05-14-2025

Products

VMware Aria Suite

Issue/Introduction

  • You are unable to expand the plugin inventory of a vCenter service instance on the orchestrator client.
  • Workflows and actions querying the vCenter instance for objects return no results.
  • The vco-server-app.log located under /services-logs/prelude/vco-app/file-logs/vco-server-app.log contains SDK in bad health errors similar to:
    • 2024-12-13T02:29:51.344Z WARN vco [host='vco-app-' thread='taskScheduler-5' user='' org='' trace=''] {} com.vmware.o11n.plugin.vsphere.connect.SessionWrapper - session <Username>@<vCenter FQDN> SDK in bad health: java.lang.RuntimeException: java.lang.reflect.InvocationTargetException
  • Running the the workflow "Update a vCenter Server instance" temporarily resolves the issue, however it starts failing again after a few days.

Environment

Aria Automation Orchestrator 8.18.x

Cause

The issue occurs due to a defect in previous versions of the plugin.

Resolution

To resolve the issue in Aria Automation 8.18.1 or Aria Automation Orchestrator 8.18.1, apply the VMware Aria Automation 8.18.1 Cumulative Update #2 which contains a newer version of the plugin.

For Aria Automation 8.18.0 or Aria Automation Orchestrator 8.18.0, update the vCenter plugin to version 8.2.0+24578687 attached to this article.

Prerequisites

  • You have access to login to Automation Orchestrator and can access the System Settings page.
  • You must back up all VMware Aria Automation or Orchestrator appliances, at the same time - simultaneously for all nodes.
    • If you are making the snapshots manually, you must start the snapshots of the second and the third node not more than 40 seconds after you start the snapshots for the first node.
    • When you back up the VMware Aria Automation or Orchestrator appliance, disable in-memory snapshots and enable quiescing.

 Steps to update the VC plugin : 

1. Download the attached plug-in file to your local machine.
2. In Automation Orchestrator, select the System Settings.
3. On the Plug-ins card, click Open.
4. Click Add Plug-in.
5. In the General pane, click Select and add the plug-in file.
6. Select a log level.
7. Click Next.
8. Review the plug-in information, if applicable, accept the end-user license agreement, and click Install.
9. Click Upload.

The plug-in is installed or updated and the Automation Orchestrator server service is restarted.

Additional Information

Techdocs: VMware Aria Automation 8.18 - Install, update, or delete a plug-in

Confirm if the MD5 or SHA256 hash values for the plug-in 'o11n-plugin-vsphere-8.2.0+24578687.vmoapp' matches the following values:

certutil.exe -hashfile .\o11n-plugin-vsphere-8.2.0+24578687.vmoapp MD5
MD5 hash of .\o11n-plugin-vsphere-8.2.0+24578687.vmoapp:
bb7756596b2b3d00392c08e9acc569a6
CertUtil: -hashfile command completed successfully.

certutil.exe -hashfile .\o11n-plugin-vsphere-8.2.0+24578687.vmoapp sha256
SHA256 hash of .\o11n-plugin-vsphere-8.2.0+24578687.vmoapp:
624604a1aa9e1273494c21c9c84bf14452f852d1586f152dc03a2b9a8724fc59
CertUtil: -hashfile command completed successfully.

Attachments

o11n-plugin-vsphere-8.2.0+24578687.vmoapp get_app