External Monitoring tools are unable to monitor ESXi as the Serial Number in MOB shows as Unset
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External Monitoring tools are unable to monitor ESXi as the Serial Number in MOB shows as Unset

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Article ID: 384236

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Updated On:

Products

VMware vSphere ESXi

Issue/Introduction

Below is the path for getting serial Number in MOB:

content -> rootFolder -> childEntity -> hostFolder -> childEntity [select appropriate host] -> host -> hardware -> systemInfo -> serialNumber

This value of SerialNumber shows as Unset in MOB

Environment

ESXi 7.x, 8.x

Cause

The serial number is not being fetched correctly by vCenter for display in its MOB page.

The issue seems to occur due to a discrepancy in how vCenter updates and displays host serial number information.

Resolution

Disconnect and Reconnect the ESXi host. 

Once, this is done, you should be able to see the Serial Number in the following location:

content -> rootFolder -> childEntity -> hostFolder -> childEntity [select appropriate host] -> host -> hardware -> systemInfo -> serialNumber

Disconnecting and reconnecting the ESXi host forces vCenter to refresh the hardware information, including the serial number.