Network configuration on the host is rolled back as it disconnects the host from vCenter server
search cancel

Network configuration on the host is rolled back as it disconnects the host from vCenter server

book

Article ID: 384174

calendar_today

Updated On:

Products

VMware vCenter Server

Issue/Introduction

Moving pNICs on and off of a standard switch for an ESXi host through the vCenter UI will fail even when both NICs have been confirmed to be able to connect to vCenter and handle traffic properly

Environment

vCenter 8.x

ESXi 8.x

 

Cause

The teaming policy of portgroups in VIM API objects is incorrectly updated when a new vmnic is added to a standard switch.  There is insufficient logging for this behavior/error in versions the issue is reported < 8.0 P05

 

As an example: 

1. We start with 2 NICs on the standard switch:
vswitch uplinks: vmnic0, vmnic1.
Management network teaming: active[vmnic0, vmnic1], Standby[]
Management network teaming VIM API: active[vmnic0, vmnic1], Standby[]
 
2. We remove vmnic1 from switch.
vswitch uplinks: vmnic0
Management network teaming: active[vmnic0], Standby[]
Management network teaming VIM API: active[vmnic0], Standby[]
 
3. We add vmnic1 back to switch. 
vswitch uplinks: vmnic0, vmnic1
Management network teaming: active[vmnic1], Standby[]
Management network teaming VIM API: active[vmnic0], Standby[]  <-------------  FAILURE HERE
 
At this point, we have hit the issue. The Management network teaming VIM API failed to add the vmnic1 and if we attempt to remove vmnic0 at this time, we will encounter this issue and the change will subsequently be rolled back.

 

Resolution

No fix at this time for versions before 8.0 P05

Work-around: 

To work-around this issue, refresh the vCenter UI client after each action taken against the switch / pNICs.  

 

Additional Information

Engineering has identified the issue and the fix is targeted for 8.0 P05.