Subscriptions to FlexReports are not being delivered to S3 Bucket.
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Subscriptions to FlexReports are not being delivered to S3 Bucket.

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Article ID: 384168

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Updated On:

Products

CloudHealth

Issue/Introduction

Subscription to FlexReport are not being delivered to S3 bucket. However Subscription to other Saved Report are being delivered to same S3 bucket. 

Cause

The root cause often is because the AWS IAM permissions 3:GetObject is missing and that is required for FlexReports only. 


The permission needed is listed under Step 1, Part 3 of "Configure S3 Bucket to Receive Subscriptions" section: 
https://techdocs.broadcom.com/us/en/vmware-tanzu/cloudhealth/tanzu-cloudhealth/saas/tnz-cloudhealth/getting-started-with-tanzu-cloudhealth-getting-started-with-cloudhealth-reports.html#configure-s3-bucket-to-receive-subscriptions-25 

Resolution

The following is for FlexReports only:

1. In the AWS Console, select Services > IAM > Policies and locate the IAM Access Policy you are using for the Tanzu CloudHealth platform.

2. In the Permissions tab, click JSON and paste the following policy in the Permissions tab. Do not modify the policy. cht-custom-reports is a Tanzu CloudHealth bucket and should not be changed. 


{
 "Effect": "Allow",
 "Action": [
 "s3:GetObject"
 ],
 "Resource": [
 "arn:aws:s3:::cht-custom-reports",
 "arn:aws:s3:::cht-custom-reports/*"
 ]
 }