vDefend SSP Alarm: Platform Services service CPU usage is high or very high
search cancel

vDefend SSP Alarm: Platform Services service CPU usage is high or very high

book

Article ID: 384118

calendar_today

Updated On:

Products

VMware vDefend Firewall VMware vDefend Firewall with Advanced Threat Prevention

Issue/Introduction

You are running SSP 5.0 or later and have encountered an alarm with the description:
"The CPU usage of Security Services Platform service {{ .ResourceID }}/{{ .ObjID }} is currently {{ .Value }}%, which exceeds the threshold value."

This indicates that one or more services under Platform Services are experiencing high CPU usage, potentially affecting system performance and responsiveness.

Environment

vDefend SSP Version: 5.0 and later

Cause

The current CPU limits for {{ .ResourceID }} is not enough to process the current load.

Resolution

Remediation for Platform Service CPU High Alarm

1. Restart the deployment/statefulset: This should resolve transient CPU spikes.

  • Log into SSPI root shell.

k -n nsxi-platform get pod <pod-name> -o jsonpath='{.metadata.ownerReferences[0].kind}'

If the output is StatefulSet, follow the StatefulSet restart steps.
If the output is ReplicaSet, it belongs to a Deployment 

If {service-name} is stateful set, run:

k -n nsxi-platform rollout restart statefulset {{ .ResourceID }} 

Otherwise, run:

k -n nsxi-platform rollout restart deployment {{ .ResourceID }}

to check restarted pod are up

k -n nsxi-platform get pods

Wait for ~20 minutes and check if the alarm is auto-resolved.

Open a ticket with Broadcom Support, if the alarm persists.