vDefend SSP Alarm: Metrics service Memory usage is high or very high
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Article ID: 384111
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Updated On:
Products
VMware vDefend FirewallVMware vDefend Firewall with Advanced Threat Prevention
Issue/Introduction
For SSP 5.0 and later
Alarm with the below description be seen
" The memory usage of Metrics service {service-name }/{ pod } is currently { value }%, which is above the threshold value."
e.g The memory usage of Metrics service metrics-manager/metrics-manager-xxxxxxxxxx-xxxx is currently 93%, which is above the threshold value.
The memory usage of Metrics service metrics-postgresql-ha-postgresql/metrics-postgresql-ha-postgresql-0 is currently 85%, which is above the threshold value.
The {service-name} will be any of the following
metrics-manager
metrics-query-server
metrics-app-server
metrics-db-helper
metrics-postgresql-ha-postgresql
metrics-postgresql-ha-pgpool
The { pod } is dynamic and will be prefixed by the service name i.e. metrics-manager-xxxxxxxxxx-xxxxx
The { value } will be dynamic and will represent the current memory usage of the { pod }
If the alarm stays open for more than 30 minutes or if its occurring multiple times, please proceed to the Resolution section
Environment
vDefend SSP >= 5.0
Cause
The current memory limits for {service-name} is not enough to process the current load
Resolution
Maintenance window required for remediation? No
Try re-starting the deployment/statefulset. This should take care of any transient issues
Log into SSPI root shell
If {service-name} is metrics-postgresql-ha-postgresql
Run 'k rollout restart statefulset metrics-postgresql-ha-postgresql -n nsxi-platform'
else
Run 'k rollout restart deployment {service-name} -n nsxi-platform'
Wait for ~20 minutes and check if the alarm is auto-resolved.
If the alarm persists, follow the steps below if {service-name} is metrics-manager , metrics-query-server or metrics-app-server follow the steps below to scale-out the service
On the Security Services Platform UI
Navigate to System | Platform & Features | Core Services
On the Metrics tile click Scale Out
Log into SSPI root shell
Run 'k rollout restart deployment {service-name} -n nsxi-platform'
Run 'k rollout restart deployment metrics-manager -n nsxi-platform'
For any other service, please open a ticket with Broadcom Support