Performance Manager Spectrum synchronization is taking long time to complete.
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Performance Manager Spectrum synchronization is taking long time to complete.

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Article ID: 384062

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Updated On:

Products

Network Observability

Issue/Introduction

We have noticed the Spectrum synchronization in Performance Manager is taking a long time to complete. Sometimes up to 10 hours.

Environment

Version: DX Netops 23.3.12 and below
Component: Performance Manager integration with Spectrum

Cause

This can be caused by a large netqos_integ mysql database on the OneClick system configured with the Performance Manager integration.

Resolution

To the following to add a new index to the netqos_integ mysql database on the OneClick system configured with the Performance Manager integration:

  • Log into the OneClick system configured with the Performance Manager integration
  • If running Windows, start a bash shell by running "bash -login"
  • cd to the $SPECROOT/mysql/bin directory and run the following command replacing <PASSWD> with the mysql root user password:

./mysql --defaults-file=../my-spectrum.cnf -uroot -p<PASSWD> netqos_integ -e "ALTER TABLE item_model_mapping ADD INDEX ItemID_ModelHandle_idx (item_id, model_handle);"

Additional Information

This index is included in 23.3.13 and above