HA probe upon starting issues false alarm stating "Lost contact" when it makes initial contact.
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HA probe upon starting issues false alarm stating "Lost contact" when it makes initial contact.

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Article ID: 384050

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Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM)

Issue/Introduction

When starting the robot with the HA probe, it restores the connection to the configured hub.  However, it is sending a "Lost contact" alarm.  When this occurs, the logs show messages similar to the following:

<Date Time> 0 HA: INFO: FAILBACK: Connection to '/UIMDomain/UIMHub/UIMRobot/hub' restored. Issuing state change.
<Date Time> 4 HA: INFO: Enter: state_check
<Date Time> 3 HA: INFO: state == '0'
<Date Time> 3 HA: INFO: gConnected: 0
<Date Time> 5 HA: ciOpen - cache path: /opt/nimsoft/niscache
<Date Time> 2 HA: ciOpen - initializing global CI cache
<Date Time> 1 HA: ciGetDeviceIdentifiers - host=/UIMDomain/UIMHub/UIMRobot/hub ip=<IPAddress> probe= [DFCD2694BD9B289646137143BF616F998]
<Date Time> 2 HA: ciRead - reading DEV  [DFCD2694BD9B289646137143BF616F998]
<Date Time> 1 HA: INFO: expanded 'Nimsoft : [NP2700001] Lost contact with remote Hub $remote_hub' to 'Nimsoft : [NP2700001] Lost contact with remote Hub /UIMDomain/UIMHub/UIMRobot/hub'
<Date Time> 2 HA: ciSaveMetric - saving MET [M6CCD5BCCFDE2E3BE7A2E5DACA845816F] 10.1:4
<Date Time> 4 HA: CONNECT: 0xbbaf00(5) <IPAddress>/49216-><IPAddress>/48001
<Date Time> 5 HA: ciPostMessage - alarm

Environment

HA 20.40

Cause

Defect in the HA probe

Resolution

freshly released HA 20.50 fixes the problem - please deploy this package to the problematic HUB and the message should disappear.