Troubleshooting automation Connection Issues in ConnectALL
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Troubleshooting automation Connection Issues in ConnectALL

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Article ID: 383977

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Updated On:

Products

ConnectAll On-Prem ConnectALL ConnectAll SaaS

Issue/Introduction

There are numerous reasons why an automation's connection to a target system may fail in ConnectALL.  These can range from network connectivity issues to authentication issues and this document lays out some ways to troubleshoot.

It is also important to note that what the user interface displays may be a generic or slightly misrepresented error message, so it is typically a best practice to analyze the log files to find out the true cause.

Note that this document will focus on automation connection issues as opposed to user interface (UI) connection issues since those are two different code paths.  However, we may use the UI to help us troubleshoot, but also some of the errors mentioned here may also be application to issues in the UI.

While troubleshooting connection issues, it is highly recommended to have a standard set of network diagnostic tools installed.  Additionally if a support ticket is raised, it may be requested that some tools be installed and failure to install these tools may delay resolution or prevent resolution altogether.

Recommended tools include

  • ping
  • traceroute
  • netstat
  • curl
  • Java Development Kit (OpenJDK is acceptable)

Some of these tools may be installed by default such as ping and traceroute, or tracert on Windows.

Cause

Here are some common issues when a connection suddenly fails

  • Authentication failure
  • SSL certificate expiration
  • Proxy server changes
  • Firewall changes
  • Router changes

Each of these requires different approaches to troubleshooting

Resolution

Authentication

Authentication errors may vary from system to system.  For example a Jira authentication may look different from a Rally authentication error, however in general they will include some verbiage about bad username and password and possibly a reference to a 401 HTTP error.  Here is a sample from Microfocus ALM:

com.go2group.connectall.adapter.model.restclient.JerseyCookieBasedRESTClient: Unauthorized: Authentication is required and has failed or has not yet been provided. Returned HTTP response:Response Status: 401

 

SSL Certificate

Caused by: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target

This log entry indicates that there is an issue with the certificate chain, such as an expired certificate, invalidated certificate, or missing root, intermediate or server certificate.  Verify that the cert chain is valid.  Bear in mind that if using a proxy server, the proxy server's own certificate chain may play into this as well, so it is important to verify those certificates as well.

 

Proxy Server

If a proxy server is causing the failure there may be a variety of errors that are present, depending on the reason the proxy request is failing.  One possible failure is if the ConnectALL host is unable to perform a DNS lookup.  In this case the error will look similar to the following:

Caused by: javax.ws.rs.ProcessingException: java.net.UnknownHostException: proxy.example.net

This can be cause by a DNS lookup failure to your proxy server.  Verify the hostname of the proxy server in your config.

You can test this outside of ConnectALL with the following command:

curl -X <proxy host:port> <target host>

Example:

curl -X proxy.example.net:8080 https://rally1.rallydev.com

 

Response:

<html><head><script type="text/javascript">...

If you receive a response such as the following then it further points to a DNS issue:

curl: (6) Could not resolve host: proxy.example.net