Inconsistency between kernel data and the configtore can happen when adding the same allowed IP addresses.
search cancel

Inconsistency between kernel data and the configtore can happen when adding the same allowed IP addresses.

book

Article ID: 383889

calendar_today

Updated On:

Products

VMware vSphere ESXi

Issue/Introduction

When trying to add an IP address entry to 'IP LIST' via vCenter UI, it might fail with "Already exists" error. 

Environment

VMware vSphere ESXi

Cause

The issue may occur if an attempt is made to add the same IP address entries to the 'IP LIST' that were processed previously.

In this case, the configstore does not contain the IP address entry, but the IP address remains in vsish.

As a result, we are eventually notified that the IP address already exists, even though it is not visible in the vCenter UI.

 

Resolution

Workaround:

To address this issue, customers can reboot the node, after which they should be able to successfully add the IP address to the 'IP LIST'