Unable to change PNID
search cancel

Unable to change PNID

book

Article ID: 383882

calendar_today

Updated On:

Products

VMware vCenter Server

Issue/Introduction

  • There is a PNID mismatch.
  • When attempting to change the PNID using the VAMI, the "Next" button may be grayed out.
  • Changing the PNID from the VAMI to a valid PNID may not be possible.

Environment

VMware vCenter Server 8.0.x

Cause

In some cases, the PNID was changed manually. Reconfiguring the PNID may not have been completed correctly or an unsupported method of changing the PNID was used. 

Resolution

To resolve this issue:

  • Please ensure to have a snapshot and a file-based backup of the vCenter before performing the steps below.

 

Set the PNID to a temporary name such as "localhost" and then reconfigure the PNID to the desired FQDN using one of the methods below:

Note: Ensure that the vCenter has the correct entries in DNS for forward and reverse lookup before performing the steps below.

 

Method 1:

1. Change the PNID to "localhost" using the utility below:

#/opt/vmware/share/vami/vami_config_net


0)      Show Current Configuration (scroll with Shift-PgUp/PgDown)
1)      Exit this program
2)      Default Gateway
3)      Hostname
4)      DNS
5)      Proxy Server
6)      IP Address Allocation for eth0

2. Choose option 3) Hostname and enter "localhost"

New hostname [vCenter]: localhost

3. Choose option 1) Exit this program

4. Login to the VAMI (https://vCenter-IP-address-or-FQDN:5480) and ensure that the hostname is set to "localhost".

5. Reconfigure the PNID from "localhost" to the FQDN of the vCenter using the VAMI, see Reconfigure the Primary Network Identifier.

6. Ensure that the PNID was successfully updated in the VAMI.

 

Method 2:

1. Change the PNID to "localhost" using the VAMI, see Reconfigure the Primary Network Identifier.

2. Refresh the VAMI webpage and ensure that the hostname is set to "localhost".

3. Reconfigure the PNID from "localhost" to the FQDN of the vCenter using the VAMI, see Reconfigure the Primary Network Identifier.

4. Ensure that the PNID was successfully updated in the VAMI.

 

 

Additional Information

After completing the PNID change workflow, it has been observed that the "vmware-stsd" service may not start back up. 

- See The vmware-stsd service fails to start due to multiple machine accounts with the same sAMAccountName