SSO users (SAML) not visible after disabled the native users
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SSO users (SAML) not visible after disabled the native users

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Article ID: 383825

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Updated On:

Products

CA Test Data Manager (Data Finder / Grid Tools)

Issue/Introduction

The SSO users (SAML) are not visible after we disabled the native users.

We followed the instructions found in the TDM 4.11 documentation: Disable Native Users in AD/LDAP Mode, but now we only see the LDAP users in TDM Portal.

Environment

TDM Portal 4.11

Cause

The mentioned documentation is how to disable native users in TDM Portal for the AD/LDAP mode. With the current implementation of the SSO/SAML integration, if native users are disabled and LDAP is enabled, no matter if SSO/SAML is used or not, then ONLY LDAP users are displayed. For TDM Portal 4.11.138.0 and older, the only way to show SSO/SAML users when native users are disabled is to disable LDAP first.

Resolution

This behavior has changed in TDM Portal 4.11.139.0 and newer. Now both LDAP and SSO/SAML user accounts will be displayed.

Additional Information

Note: GT Datamaker does not support SSO/SAML integration. Only native users, or LDAP users, are able to log into GT Datamaker.

The latest TDM patches are available for download from the Test Data Manager (TDM) Support Patches page.