SDWAN-Client user authentication prompt reappears and SD-Access authentication does not happen
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SDWAN-Client user authentication prompt reappears and SD-Access authentication does not happen

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Article ID: 383780

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Updated On:

Products

VMware VeloCloud SD-Access

Issue/Introduction

SDWAN-Client user authentication prompt reappears even after providing login credentials.

The user neither gets authenticated nor get authentication error.

Environment

Velocloud SDWAN, SDWAN-Client, Velocloud SD-Access, VMware SDWAN Client, SODA

Cause

The SDWAN-Client application runs multiple processes and sdwan-client-service is one of them.
It takes care of the interaction between UI and other modules. These are automatically started by the OS post bootup.

If sdwan-client-service fails to get launched, then none of the other modules will be responding and user authentication wont be successful.

Sample output from Windows:

Go to Windows Task Manager and check status of sdwan-client-service.
The services should be running as background process.

Apart from this you can also find another process running as SD-WAN Client 

Sample output from MAC:

Go to MAC terminal and check for the status of sdwan-client service (ps -aef | grep sdwan-client-service)

Other SDWAN Client processes running on MAC 

Resolution

If the sdwan-client-service is not running on the background, the service needs to be restarted.

Windows OS:

Go to services and check for SD-WAN Client Service . Click on "Start the service"

 

MAC OS:

Open Terminal on MAC and issue below commands.

ls -l /Library/LaunchDaemons/com.vmware.orchestrator.sdwanclient.service.plist
sudo launchctl load /Library/LaunchDaemons/com.vmware.orchestrator.sdwanclient.service.plist

Additional Information

If issue still persists please collect the logs as instructed in the KB-368552

Please open a case with Broadcom Support for SD-Access along with the logs.