Tag-based alert does not trigger when one tag is defined in the symptom definition while VMs have multiple tags
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Tag-based alert does not trigger when one tag is defined in the symptom definition while VMs have multiple tags

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Article ID: 383643

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Updated On:

Products

VMware Aria Suite

Issue/Introduction

Tag-based alert does not trigger when one tag is defined in the symptom definition during the alert creation while VMs have multiple tags.

Environment

Aria Operations 8.x

Cause

Contains or Equals was the chosen operator during the alert creation, and the objects have multiple vSphere tags assigned.

Resolution

Note: This is customization to figure out what should be configured to achieve the goal. It is not within Broadcom Global Support's break/fix scope. If further assistance is needed, TAM or the account team should be the resource to reach out.

To resolve the issue, since Aria Operations collects all vSphere tags into a single string, it is required to use the Matches regular expression operator to account for the possibility of multiple tags present.

For example, if all VMs assigned with multiple tags have a mutual tag A being the first tag, and the alert needs to be triggered on VMs with tag A. The following setting should be configured:

If Summary|vSphere Tag Matches regular expression ^.*A.*$

See screenshot below: