Data from CAMM is Showing as Dots and not a continuous line
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Data from CAMM is Showing as Dots and not a continuous line

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Article ID: 383566

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Updated On:

Products

Network Observability CA Performance Management CA Mediation Manager

Issue/Introduction

When displaying data on the chart with a timescale of 5 minutes, only dots are shown, not a continuous line:

However, when a timescale of 15 minutes is selected, it shows correctly.

Environment

DX NetOps CA Performance Management (CAPM) & CA Mediation Manager (CAMM) all currently supported releases

Cause

When the data is queried in the DB, it shows 15 minute poll samples which is the sampling time of the CAMM device pack:

dradmin=> select i.item_display_name, i.item_id, i.description, to_timestamp(f.tstamp) as timestamp from dauser.item i join dauser.ifstats_rate f on f.item_id = i.item_id where i.item_name = 'PE--Int' order by 4;

 item_display_name | item_id | description  |      timestamp
-------------------+---------+--------------+---------------------
PE--Int            |  702697 | PE Interface | 2024-11-20 03:00:00

PE--Int            |  702697 | PE Interface | 2024-11-20 03:15:00
PE--Int            |  702697 | PE Interface | 2024-11-20 03:30:00
PE--Int            |  702697 | PE Interface | 2024-11-20 03:45:00

So when plotted on a 15 min timescale, it shows a contiguous line. However, when you change the timescale to LESS than the polling time, then CAPM doesn't fill in the gaps as it cannot interpolate what happened between those poll sample times. So you just get the dot points.

Resolution

This is working as designed. Select a Timescale for the report that is the same or greater than the poll time period.

Note though, that once the data gets to 1 hr sample resolution due to rollup, it won't make a difference and continuous lines will be shown.