Symantec Identity Manager Incorrect data displayed in Approver List
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Symantec Identity Manager Incorrect data displayed in Approver List

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Article ID: 383499

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Updated On:

Products

CA Identity Suite

Issue/Introduction

 

A task with three-stage approval configured in an assigned provisioning role event.

Task Name: EXT_SDP_CR_AGENT

Provisioning Role Name: EXT_SDP_CR_AGENT

Initiator: XYZ

Target user: Test_User1 , Full Name: TestUser1

1st Level : Users Manager = TestUser2

2nd level : Group member =TestUser3

3rd Level : Group Memmber = TestUser4 and TestUser5

A User TestUser6 is neither an approver, target user nor an initiator for the first task. However, the approval list shows XYZ123 as a second-level approver. which is not correct, also second-level approval was already approved.

A Separate task has been initiated for the same user within the same time frame. With a similar configuration (three-stage approval) with second-level approval as TestUser5
Looks like there is a mismatch.

This issue is observed only when 2 tasks are triggered at the same time.

This issue looks similar to one of the IP 14.5 known issues.
https://techdocs.broadcom.com/us/en/symantec-security-software/identity-security/identity-portal/14-5/release-notes/known-issues.html

 

Environment

14.5.1

Cause

Known Issue:

Adding Multiple Groups to Users using Relations in Module Actions
When using Relations in Module Actions to add multiple groups to a user, and the task being used has workflows on the Add to group event, the following behavior is expected:
There would be multiple "Add to group" events and appropriate workflows based on the number of groups added in the request.
In the My Requests screen, the workflows are displayed in a confusing manner; as if the workflows are combined into a single one.
In the Tasks screen, the approver can view multiple work items but the request information in multiple items looks identical. The approver cannot figure out which item is related to which group. 

Resolution

An HF HF_IP-14.5.1-20241205142826-DE619052.tgz.gpg is now available to download. Please raise a support ticket and request for the HF

Reference Defect: DE619052