sdgtw probe Incidents are not getting generated in servicenow
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sdgtw probe Incidents are not getting generated in servicenow

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Article ID: 383479

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Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM)

Issue/Introduction

The sdgtw probe is unable to generate incidents after trying to clone the service now profile.

The tickets queue in the hub is yellow and not sending tickets.

sdgtw logs shows:

Dec 03 15:30:03:129 [main, sdgtw] MDR ID is ServiceNow
Dec 03 15:30:03:129 [main, sdgtw] ::: going to call parseResponse ::: URL ::MDR http://localhost:example=ServiceNow :: ServiceNow
Dec 03 15:30:03:172 [main, sdgtw] responseCode :: [500] response message :: [Internal Server Error]
Dec 03 15:30:03:172 [main, sdgtw] stderr: java.lang.Exception: {"Error":{"ErrorCode":151,"ErrorMessage":"Please check the configuration for ServiceNow(ServiceNow)","HTTPResponseCode":"BAD_REQUEST","HTTPResponseCodeValue":500}}
Dec 03 15:30:03:172 [main, sdgtw] stderr:     at com.ca.integration.normalization.client.HttpRequestHandler.parseResponse(HttpRequestHandler.java:182)
Dec 03 15:30:03:172 [main, sdgtw] stderr:     at com.ca.integration.normalization.client.HttpRequestHandler.get(HttpRequestHandler.java:70)
Dec 03 15:30:03:172 [main, sdgtw] stderr:     at com.ca.integration.normalization.client.NIMRestClient.get(NIMRestClient.java:136)
Dec 03 15:30:03:172 [main, sdgtw] stderr:     at com.ca.integration.normalization.client.NIMRestClient.getCIProperties(NIMRestClient.java:511)

Environment

Release: DX UIM 23.4

Component: sdgtw 2.34

Cause

Cloning profile for the service now profile leads into this issue.

Resolution

•  After reconfiguring the profile(just remove entries and add again - Username and Password ) and hard restarting the probe the issue was resolved. 

•  Cloning the Profile in order to point it to the TEST environment generates this issue (production ticket creation stopped).