Intermittent login failures post directory deletion/rebuild on the VIDM
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Intermittent login failures post directory deletion/rebuild on the VIDM

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Article ID: 383444

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Updated On:

Products

VMware Aria Suite

Issue/Introduction

The mismatch and orphaned VIDM state configuration information can lead to random failed login attempts.

Environment

VIDM 3.3.7

Cause

The VIDM configuration state was left in database and filesystem after a directory rebuild/deletion on the VIDM

Resolution

Note: Take offline snapshots of all VIDM appliances

  1. Access the DB and run the below query
            psql -U postgres -d saas;
          select "id","host" from "Connector" where "tenantId"='<Tenant Name>';
  2. Now ssh to all the vidm nodes and go the path /
            cd /usr/local/horizon/conf/states/<Tenant Name>
            Note down the 4 digit "id" from each node and cross check with the DB entry ("id") from above result. If the "id" is not present in the DB and present in the file system.. we need to clean this "id" from the file system.
  3. From the above we can find out which VIDM nodes have the stale entries. Note down the nodes having the stale "id"
  4. To clean up ssh to the VIDM nodes having stale worker "id" [from 3 above] and stop the horizon service
        service horizon-workspace stop
  5. Go to the path mentioned and perform the step below
            cd /usr/local/horizon/conf/states/<Tenant Name>
            rm -rf <staleworkerid>
  6. Repeat the above step for the Tenants
  7. Start the horizon service on the VIDM nodes
        service horizon-workspace start