Intermittent login failures post directory deletion/rebuild on the VIDM
book
Article ID: 383444
calendar_today
Updated On:
Products
VMware Aria Suite
Issue/Introduction
The mismatch and orphaned VIDM state configuration information can lead to random failed login attempts.
Environment
VIDM 3.3.7
Cause
The VIDM configuration state was left in database and filesystem after a directory rebuild/deletion on the VIDM
Resolution
Note: Take offline snapshots of all VIDM appliances
Access the DB and run the below query psql -U postgres -d saas; select "id","host" from "Connector" where "tenantId"='<Tenant Name>';
Now ssh to all the vidm nodes and go the path / cd /usr/local/horizon/conf/states/<Tenant Name> Note down the 4 digit "id" from each node and cross check with the DB entry ("id") from above result. If the "id" is not present in the DB and present in the file system.. we need to clean this "id" from the file system.
From the above we can find out which VIDM nodes have the stale entries. Note down the nodes having the stale "id"
To clean up ssh to the VIDM nodes having stale worker "id" [from 3 above] and stop the horizon service service horizon-workspace stop
Go to the path mentioned and perform the step below cd /usr/local/horizon/conf/states/<Tenant Name> rm -rf <staleworkerid>
Repeat the above step for the Tenants
Start the horizon service on the VIDM nodes service horizon-workspace start