vSAN Skyline Health reports error - "Physical disk health retrieval issue".
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vSAN Skyline Health reports error - "Physical disk health retrieval issue".

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Article ID: 383362

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Updated On:

Products

VMware vSAN

Issue/Introduction

Symptoms:

  • vSAN Skyline Health reports the error: "Physical disk health retrieval issue". One or more disks show as unhealthy.
  • One or multiple disks shows unhealthy.

Environment

VMware vSAN 6.x
VMware vSAN 7.x
VMware vSAN 8.x

Cause

This issue might occur if there is an unknown or stale disk present on the host that is not recognized by CMMDS (Cluster Monitoring, Membership, and Directory Services). This discrepancy can trigger the "physical disk health retrieval" alarm, causing the disks to show as unhealthy.

Resolution

  1. Check for unhealthy disks in vCenter:
    Navigate to Cluster > Configure > Disk Management.
  2. Run the following command to identify any missing disks 
    "vdq -iH"
    DiskMapping[0]:
               SSD:  naa.xxxxxxxxxxxxxxxx
                MD:  naa.xxxxxxxxxxxxxxxx
                MD:  naa.xxxxxxxxxxxxxxxx
     
       DiskMapping[2]:
               SSD:  naa.xxxxxxxxxxxxxxxx
                MD:  naa.xxxxxxxxxxxxxxxx
                MD:  naa.xxxxxxxxxxxxxxxx
                MD:  naa.xxxxxxxxxxxxxxxx
     
       DiskMapping[4]:
               SSD:  naa.xxxxxxxxxxxxxxxx
                MD:  naa.xxxxxxxxxxxxxxxx
                MD:  naa.xxxxxxxxxxxxxxxx
                MD:  naa.xxxxxxxxxxxxxxxx
  3. Run the following command to detect unknown or stale disks
    "esxcli vsan storage list"
    Unknown:
       Device: Unknown
       Display Name: Unknown
       Is SSD: false
       VSAN UUID: yyyyyyyy-yyyy-yyyy-yyyy-yyyyyyyyyyyy
       VSAN Disk Group UUID:
       VSAN Disk Group Name:
       Used by this host: false
       In CMMDS: false
       On-disk format version: -1
       Deduplication: false
       Compression: false
       Checksum:
       Checksum OK: false
       Is Capacity Tier: false
       Encryption Metadata Checksum OK: true
       Encryption: false
       DiskKeyLoaded: false
       Is Mounted: false
       Creation Time: Unknown
  4. Take necessary actions if a missing disk is identified. Please refer this KB to troubleshoot vSAN OSA disk issues: How to troubleshoot vSAN OSA disk issues
  5. Place the host in maintenance mode and reboot the host, if the stale or unknown disk persists.