Unable to remove the Software Catalog menu from being displayed
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Unable to remove the Software Catalog menu from being displayed

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Article ID: 383312

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Updated On:

Products

IT Management Suite

Issue/Introduction

You created a custom Security Role by cloning a default one, the "Symantec Level 2 Workers". This custom Security Role should only have access to certain menus, like the "Settings" menu for example. However, you don't want the "Manage" menu to be accessible / visible.

After granting and removing the proper Permissions and Privileges on what you want to be accessed in the SMP Console, you still see "Manage > Software Catalog" as a console menu

Even when it is not one of the selected items in Security Role Manager.

Environment

ITMS 8.7.x

Cause

There were some inherited permissions coming from the "NT Authority\Authenticated Users" role.

Resolution

In order to completely remove "Software Catalog" (even when it does not do anything when clicked), try the following:

  1. Open Security Role Manager (SMP Console > Settings > Security > Security Role Manager)
  2. Switch to "Console Menu" under View" and click on "Manage>Software Catalog"
  3. Right-Click on "Software Catalog" and select "Properties"

  4. Select the "Security" Tab and then click "Advanced" button in bottom right of the page



  5. On the "Permissions for: Software Catalog" page, select the "NT Authority\Authenticated Users" security role.
  6. Uncheck all the available options that are selected so you can remove all the permissions associated to this "NT Authority\Authenticated Users" security role.

  7. Click Save Changes, and close the Permissions for: Software Catalog window.  Close Security Role Manager.
  8. Go ahead and now try to access the SMP Console with the desired account that is a member of the custom Security Role. You should not be able to see "Manage > Software Catalog" menu anymore.



  9. If you still do, repeat the same steps above but now do them against "NT Authority\System" role and make the same changes.



  10. Refresh the browser on your Custom Security Role, and you should see the Manage button is no longer visible to this custom role. 

Additional Information

"Removing Console Menu item: Manage from the console for a Custom Security Role" (KB 266480)