"Failed to update settings.Response status code: 503" message when attempting to upgrade from 8.16 to 8.18 via CDROM.
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"Failed to update settings.Response status code: 503" message when attempting to upgrade from 8.16 to 8.18 via CDROM.

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Article ID: 383292

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Updated On:

Products

VMware vRealize Suite Lifecycle Manager 8.x

Issue/Introduction

  • Navigating to Home -> Settings -> System Upgrade  to attempt to upgrade from 8.16 to 8.18 via CDROM results in a "Failed to update settings.Response status code: 503" message.
  • The vrlcm log /var/log/vrlcm/vmware_vrlcm.log has an "Failed to fetch CAP update status" message similar to:
ERROR [http-nio-8080-exec-4] c.v.v.l.u.u.LCMUpgradeUtil -  -- Failed to fetch CAP update status.
INFO  [http-nio-8080-exec-4] c.v.v.l.u.u.LCMUpgradeUtil -  -- {"id":"ms_error_internal_error","locale_id":"en-us","default_message":"Internal error: dial unix /tmp/cap-ams-faas-appliance_update.socket: connect: connection refused","args":["dial unix /tmp/cap-ams-faas-appliance_update.socket: connect: connection refused"]}
ERROR [http-nio-8080-exec-4] c.v.v.l.l.s.VrslcmUpdateServiceImpl -  -- Exception while getting upgrade status for vRLCM. com.vmware.vrealize.lcm.lcops.common.exception.CAPException: Failed to fetch CAP update status
ERROR [http-nio-8080-exec-4] c.v.v.l.l.c.LcmManagementController -  -- Exception occurred while checking upgrade status.
com.vmware.vrealize.lcm.lcops.common.exception.CAPException: Failed to fetch CAP update status

Environment

VMware Aria Suite Lifecycle 8.16

Cause

This issue can occur when cap service is not able to create the socket file before timeout.

Resolution

To workaround the issue:

  1. Snapshot the Aria Suite Lifecycle appliance.
  2. SSH to the Aria Suite Lifecycle appliance and login with root user.
  3. Check the status of the cap service: 
    systemctl status cap-appliance-management.service
  4. Restart the status of cap service:
    systemctl restart cap-appliance-management.service
  5. Try again to upgrade Lifecycle Manager.If it's not working,continue to step 5.
  6. Increase the "service timeout" value in file
    etc/vmware/cap/cap_am/cap-appliance-management.conf from 1 to a maximum of 60 seconds.
  7. Retry the upgrade.
  8. If the preceding steps do not resolve revert to snapshots taken in the first step and contact VMWare Support.