PIM(ENTM): ポリシーの再デプロイを行うと キューに入ったままになる。
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PIM(ENTM): ポリシーの再デプロイを行うと キューに入ったままになる。

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Article ID: 383257

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Products

CA Privileged Identity Management Endpoint (PIM) CA Privileged Access Manager - Server Control (PAMSC)

Issue/Introduction

Privileged Identity Manager ( 以下、PIM) のエンドポイントの seosdb が不整合が発生し、再作成を行う必要があった。
seosdb の再作成後、いくつかのルールが消えていたので、エンタープライズ管理でポリシーの再デプロイを行ったが、キューのまま処理が動かない。

メッセージキューは正常に稼働しており、キューのバックアップは行われていない。

Environment

Privileged Identity Manager: 全バージョン

Privileged Access Manager Server Control: 全バージョン

Cause

このエンドポイントでは、seosdb データベースの再構築に問題があり、 seosdb データベースのポリシー情報が不完全となったため、 policyfetcher がルールを正しく取り出すことができなくなりました。

エラーは /opt/CA/AccessControl/log/policyfetcher.log に記録されており、GPOLICY または RULESET の関連付けが欠落していたため、ポリシーの削除中にエラーが発生したことが示されていました。

Resolution

解決するためには次の手順で seosdb の作成と DMS の HNODE 情報のリセットが必要となります。

最初は エンドポイント側で以下の操作を行います。

  1. エンドポイントの停止
    # secons -S
  2. seosdb をバックアップする
    # /opt/CA/AccessControl/bin/dbmgr -e -r -f ~/seosb.exp.`date +"%m-%d-%y"`
  3. 新規のデフォルトデータベースを再作成する。
    # cd /opt/CA/AccessControl/seosdb
    # /opt/CA/AccessControl/bin/dbmgr –create –cq –u root –t <terminalname>
  4. エンドポイントをエンタープライズ管理サーバと通信できるように構成する。
    ( 実際には entmservername はエンタープライズ管理サーバと入替えてください。)
    # selang -l
    AC> so dh+(DH__@entmservername)
    AC> exit
  5. 引き続き PIM サービスは停止したままにしておきます。

次に エンタープライズ管理サーバでコマンドプロンプトを開いて以下の作業を行います。
(endpointname は問題が発生しているエンドポイント名で置き換えてください。)

# selang
AC> host DMS__@
AC> rr HNODE <endpointname>
AC> sr deployment * gen_prop(HNODE_NAME) gen_val(HNODE.<endpointname>)
(この時、該当するレコードは0件になるはずです。)
AC> exit
# dmsmgr -sync self

全部完了したら、HNODE と 関連するデプロイメントはエンタープライズ管理サーバから削除されます。
エンドポイントを再起動することで数分程度で、policyfetcher が開始し、情報を エンタープライズ管理サーバへ格納していきます。

最後に、エンタープライズ管理サーバの GUI からログインし、ポリシーをエンドポイントにデプロイしてください。
policyfetcher が再起動されるかジョブが走ると正しくポリシーが反映されました。

Additional Information

こちらの文書は以下の英文のKBを翻訳、加筆、修正しました。

Article ID: 230694: Attempting to Redeploy a Policy Results in a Queued State