Custom Logo in Service Point Is Not Displaying
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Custom Logo in Service Point Is Not Displaying

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Article ID: 383215

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Updated On:

Products

CA Service Management - Service Desk Manager CA Service Desk Manager

Issue/Introduction

After configuring a custom logo using the following instructions:

Customize the URL Branding

The custom logo is not being displayed as expected.

The default logo is not displayed and only a broken image is seen.

Environment

Service Desk Manager 17.4.x

Cause

DB configuration the casm_picture table has an incorrect configuration

Resolution

First, confirm if data is present in the following tables:

  • casm_picture
  • casm_picture_data

Backup these tables.

Update casm_picture table by modifying the code column to NULL for all rows with the previously configured name:

update casm_picture set code='NULL' where code='<PREVIOUS_CODE>'

Navigate to the default location:

C:\Program Files\CA\xFlow\APPS\Services\incidentmicroservice-17.0.479\public\conf

Then, open casm.conf.js file in a text editor.

Update the following lines like this:

logo : 'assets/images/logos/<Newlogo imagename>',
    bui_branding : {
           builogo : 'assets/images/logos/<Newlogo imagename>', 
           brandname : '<New brand name>'', 

Save your changes

Restart xFlow services

Clear browser cache or test in Incognito mode