SAL (Single Agent for Linux) isn't connecting to the Symantec Endpoint Protection Manager despite all services running correctly
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SAL (Single Agent for Linux) isn't connecting to the Symantec Endpoint Protection Manager despite all services running correctly

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Article ID: 383103

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Updated On:

Products

Endpoint Protection

Issue/Introduction

SAL (Single Agent for Linux) isn't connecting to the Symantec Endpoint Protection Manager. The following error message can be found in the cve.log:

2024-11-28T11:11:18.843CET 139791018473216 INFO cve.sylinkcommunicator [2024-Nov-28 11:11:18.843432] [INFO ] Starting heartbeat. [thread:7f23a1ffb700]
2024-11-28T11:11:18.844CET 139791018473216 INFO cve.sylinkcommunicator [2024-Nov-28 11:11:18.844368] [INFO ] Don't connect to server because AlwaysConnect = 0. [thread:7f23a1ffb700]

Cause

The sylink.xml file is empty

Resolution

Please export a fresh sylink.xml file from your SEPM:

Exporting and importing the client-server communications file (Sylink.xml) manually

Transfer it to the impacted Linux server and use the following command to import it:

/opt/Symantec/sdcssagent/AMD/tools/sav manage -i <path-to-your-sylink.xml>