Remediate password task in SDDC Manager UI fails if the password has specific special characters
search cancel

Remediate password task in SDDC Manager UI fails if the password has specific special characters

book

Article ID: 383098

calendar_today

Updated On:

Products

VMware SDDC Manager

Issue/Introduction

  • Running the REMEDIATE password operation from the SDDC Manager UI fails with the error below, even though the correct password is entered:

    Cannot complete login due to an incorrect user name or password.

  • The password put in contains one or more of the following special characters: & < > ' "

Cause

The SDDC Manager does not support specific special characters for component account passwords.

Resolution

VMware by Broadcom is aware of this issue and is working to resolve it in a future release.

Workaround

  1. Change the password of the affected user/account to exclude the unsupported characters in the component UI (i.e., use the Host Client for ESXi, VAMI for vCenter Server, NSX Manager CLI for NSX)
  2. REMEDIATE the password with the new password in the SDDC Manager GUI.

Additional Information

Manually Update Passwords

  • At least one lowercase letter, one uppercase letter, a number, and one of the following special characters: ! @ # $ ^ *