VMware Aria Automation catalog form items in Service Broker may fail to load due to exclusive locks in Orchestrator actions which load values
search cancel

VMware Aria Automation catalog form items in Service Broker may fail to load due to exclusive locks in Orchestrator actions which load values

book

Article ID: 383053

calendar_today

Updated On:

Products

VMware Aria Suite

Issue/Introduction

Key symptom:

  • Running Display all locks workflow shows unexpected or stuck lock entries

 

Other possible symptoms:

  • Service Broker catalog items can not load their form values from Orchestrator.
  • Banner errors on forms, e.g.:  Cannot execute action <actionName> .. io.netty.handler.timeout.ReadTimeoutException
  • These form items usually load: no changes had been made recently.
  • Health of the Orchestrator service (external or embedded) is good. If it is an external Orchestrator, it can be contacted over a reliable network connection
  • Other catalog items which don't depend on this action may execute successfully, or some similar actions may also fail.

Environment

VMware Aria Automation Service Broker 8.x

VMware Aria Orchestrator 8.x

Cause

  • The action may be failing due to an exclusive lock enabled, which is blocking some part of this action
  • Library workflow Display all locks should help to figure this out

Resolution

  1. Run the Display all locks workflow to see if there are any persistent results which may explain the failure
  2. To release all locks, you can run the Release all locks workflow.