ITMS 8.7.2 - Altiris Agent on Ubuntu stops working when GlobalProtect is installed
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ITMS 8.7.2 - Altiris Agent on Ubuntu stops working when GlobalProtect is installed

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Article ID: 383027

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Updated On:

Products

IT Management Suite

Issue/Introduction

After installing Palo Alto GlobalProtect and doing a reboot the Altiris Agent stops working.
Checking with aex-helper query network reveals that the agent is disconnected.
Running top command reveals high CPU usage of aex-pluginmanager.

Environment

Reproduced with Ubuntu 22.04 and 24.04 Desktop using 8.7.2 ULM Agent.

Cause

agent is failing to query new virtual VPN adapter created by GlobalProtect

Resolution

This issue will be resolved in 8.7.3 Pointfix for ULM agent (https://knowledge.broadcom.com/external/article?articleNumber=382575)

For the 8.7.2 drop in is a "libasi.so.1.0" library. This file must be placed into "/opt/altiris/notification/nsagent/lib/" directory. Steps which can be scripted:

  1. aex-helper agent stop
  2. copy file to lib folder
  3. aex-helper agent start

This drop-in must be placed for all existing clients before GlobalProtect VPN application is installed.

Attachments

libasi.so.1.0 get_app