"Could not determine hostname" when installing new Data Collector
search cancel

"Could not determine hostname" when installing new Data Collector

book

Article ID: 38300

calendar_today

Updated On:

Products

CA Infrastructure Management CA Performance Management - Usage and Administration

Issue/Introduction

Symptoms: 

When installing a new Data Collector, after specifying the Data Aggregator IP, choosing no (for multitenancy Installation) the following error is displayed:

“Could not determine hostname, there was an error determining the hostname for this System. Please contact the System Administrator to resolve this issue. “

Environment:  

Applies to all Versions of Performance Management released to date

Cause: 

The Installer cannot resolve the correct Hostname for the Data Aggregator IP

Resolution/Workaround:

 

Verify that etc/hosts, /etc/sysconfig/network and /proc/sys/kernel/hostname contain the same fully qualified host name.

Environment

Release:
Component: IMAGGR