This document explains the following error in JFM: CAL2M170E Monitor(CA71) Terminating - Call to module L2JFDBIO failed RC(28) token(00000000)
search cancel

This document explains the following error in JFM: CAL2M170E Monitor(CA71) Terminating - Call to module L2JFDBIO failed RC(28) token(00000000)

book

Article ID: 38292

calendar_today

Updated On:

Products

CA 7 Workload Automation

Issue/Introduction

Issue:   

Following an install of CA 7 Webclient and Jobflow Monitor, the following terminating error can be produced in the JobFlow Monitor joblog

CAL2M170E Monitor(CA71) Terminating - Call to module L2JFDBIO failed RC(28) token(00000000)

 

The L2JFDBIO and CAL2M170E error messages in the JFM joblog can have multiple meanings.

 

Cause:

Configuration between CA7 Webclient and Jobflow Monitor is not configured via ENF, CA 7, TCP/IP, etc... 

 

Resolution:

There can be various adjustments made to correct the L2JFDBIO failed RC(28) token(00000000) error.  Verify that the following configuration rules are in place:

-Verify and apply the latest CA 7 and JFM maintenance

-Define the following CA 7 queues as memory-resident:

 FORMAT,DDNAME=UCC7REQQ,DISP=O,FLNAME=UCC7REQQ,INDEX=A

 FORMAT,DDNAME=UCC7RDYQ,DISP=O,FLNAME=UCC7RDYQ,INDEX=A

 FORMAT,DDNAME=UCC7ACTQ,DISP=O,FLNAME=UCC7ACTQ,INDEX=A

 FORMAT,DDNAME=UCC7PRNQ,DISP=O,FLNAME=UCC7PRNQ,INDEX=A

-Define a TCPTPORT on the UCC7VTAM statement:   

 UCC7VTAM,APPL=CA7,VTNAME=VTM,TCPTMOUT=10,TCPTPORT=xxxxx

 The TCPTPORT keyword triggers CA WA CA 7 Edition to set up the TCP/IP environment that JFM requires.

-In the CAL2OPTN library, verify that the JBFLWMN member has the following:

 MONITOR(TYPE(WARM) INSTANCE(CA71) REFRESH(30) SPAN(2) HISTORY(0) CPMSRVR(N))Note:  Values may vary, depending on site requirements

-If CPM=JFM or JFMLOAD, CPMSRVR is set to Y.

 If the CPM keyword is not provided, CPMSRVR is set to N.

-Define a CA7LOG EVENT for the JFM task.

-Start the CA7ONL task first, followed by the JFM task.

-Insure that there are no CA-7.973 in the CA 7 joblog for DATE/TIME VERIFICATION

 NECESSARY, REPLY: 'U' TO PROCEED OR 'NOSCAN' TO DISABLE SSCAN

-Verify that JFM is pointing to the correct instance of CA 7 in the CAL2OPTN(JBFLWMN) member. 

-Insure that TCP/IP has started prior to the CA7ONL task.

 

 Note:  All ports must be unique

 

 

Additional Information: 

For more information about configuring Job Flow Monitor with CA 7 Webclient, please refer to these guides:

https://support.ca.com/cadocs/7/CA%20Workload%20Automation%20CA%207%20Edition%2011%203-ENU/Bookshelf_Files/HTML/WA_SE_InterfaceRef_ENU/index.htm

https://ftp.broadcom.com/user/downloads/pub/Workload-Automation/CA%207%20Web%20Client%2011.3.3%20Cumulative%20Build%201/CA%207%20Web%20Client%20Product%20Guide.pdf

 

 

As always, please contact CA Technologies support for CA 7 if you have further questions.

Environment

Release: ESPSEV99000-11.3-CA-7-Extended Support Plus
Component: