No option available to email the Agent Summary Report as a CSV attachment in the DLP Enforce Console
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No option available to email the Agent Summary Report as a CSV attachment in the DLP Enforce Console

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Article ID: 382899

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Updated On:

Products

Data Loss Prevention

Issue/Introduction

On the System -> Agents -> Overview -> Summary Reports page in the DLP Enforce Console, after selecting the Send -> Schedule Distribution option in the menu bar at the top, There is no option to email the report as a CSV attachment.

 

Environment

16.x and older DLP Enforce Server

Cause

This is because the user's DLP role was not granted the "Email incident report as a CSV attachment" privilege under the Incidents section of the General tab.

Resolution

To be able to email the Agent Summary Report as a CSV attachment the user's DLP Role will need to be granted the "Email incident report as a CSV attachment" privilege. Unfortunately, this will also provide the user with incident privileges as well. The fact that the privilege to email the Agent Summary Report as a CSV attachment is tied to the incidents privilege is a defect which will be fixed in a later DLP version so those two privileges can be decoupled.


You must also ensure that the system general setting is enabled to send reports, and not just links.(System -> Settings -> General)