Integration Fails between SDM and Jasper
search cancel

Integration Fails between SDM and Jasper

book

Article ID: 382882

calendar_today

Updated On:

Products

CA Service Management - Service Desk Manager CA Service Desk Manager

Issue/Introduction

Running Jasper Server / SDM integration process (link), the procedure appears to be successful, no outward errors, but there are missing insights related entries in the xFlow configuration.  

the stdout.txt from the Jasper Server's root drive location, which contains the integration logging, shows "Incorrect syntax near 'organisation'" message:

XX/XX/XX 08:07:06.983 ERROR DatabasePersister.java   822 Incorrect syntax near 'organisation'.

XX/XX/XX 08:07:06.983 ERROR JasperServerConfigTask.java   207 Persist CABI details failed
java.sql.BatchUpdateException: Incorrect syntax near 'organisation'.
    at com.microsoft.sqlserver.jdbc.SQLServerStatement.executeBatch(SQLServerStatement.java:1749) ~[sqljdbc4-4.0.jar:?]
    at com.ca.smsi.installcore.Database.DatabasePersister.persistJasperServerConfigurations(DatabasePersister.java:812) ~[smsi.jar:17.4.0-SNAPSHOT-134.134]
    at com.ca.smsi.installui.tasks.JasperServerConfigTask.persistJasperServerConfigurations(JasperServerConfigTask.java:204) [smsi.jar:17.4.0-SNAPSHOT-134.134]
    at com.ca.smsi.installui.tasks.JasperServerConfigTask.run(JasperServerConfigTask.java:73) [smsi.jar:17.4.0-SNAPSHOT-134.134]
    at com.ca.smsi.wizard.task.Task.start(Task.java:240) [smsi.jar:17.4.0-SNAPSHOT-134.134]
    at com.ca.smsi.installcore.DeployThread.run(DeployThread.java:1466) [smsi.jar:17.4.0-SNAPSHOT-134.134]

Environment

Release 17.4 or higher
CA Service Desk Manager

Release 9.0 or higher
JasperReports Server

Cause

The Jasper Server was installed on a Windows server which was configured for a display language other than US/English

Resolution

Go into the Windows Server's settings on the Jasper server and change the display language to English (United States), then re-attempt the integration process.

Additional Information

Per existing documentation (link), CA Business Intelligence JasperReports Server is supported only in English.

Another way to tell that there may be an issue with the integration failing is if there are entries missing for the xFlow insights related settings.  Please see KB Article 382882  for further information.