vSphere HA Fails to configure on ESXi Host Nodes Due to Scratch Partition Configuration Conflict
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vSphere HA Fails to configure on ESXi Host Nodes Due to Scratch Partition Configuration Conflict

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Article ID: 382834

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Updated On:

Products

VMware vSphere ESXi VMware vCenter Server 8.0 VMware vSphere ESXi 8.0

Issue/Introduction

  • vSphere HA configuration on ESXi host node in a cluster fail with Network Partition Error
  • vSphere HA configuration on ESXi host node in a cluster fail with HA agent unreachable
  • The settingsd service not able to acquire lock on this file on problematic ESXi hosts

/var/run/log/settingsd.log

2024-11-08T14:53:46.728Z Er(11) settingsd[2100449]: [/var/vmware/lifecycle/task-status.json.db] unable to open DB: unable to open database file

Environment

vCenter Server 8.x and ESXi Host 8.x

Cause

The scratch partition on the affected ESXi hosts is configured to the same path (/vmfs/volumes/5dc45468-1b5***df-50d6-d0bf9cf0****). The scratch partition is used on each ESXi host to have a unique path. When multiple hosts point to the same path, it causes a conflict, preventing the settingsd service from accessing the configuration database. This results in the error message in the logs: unable to open database file.

Resolution

Please follow below steps to verify scratch partition configuration and fix the vSphere HA issue

  • Verify Scratch Partition Settings:
    Check the scratch partition settings on all affected ESXi hosts in a cluster to ensure that each host has a unique scratch partition path.

    #vim-cmd hostsvc/advopt/view ScratchConfig.CurrentScratchLocation
  • Reconfigure Scratch Partition Path:
    Assign a unique scratch partition path for each ESXi host. Ensure no two hosts share the same path.
    Steps to modify Scratch Location: Creating a persistent scratch location for ESXi 8.x/7.x/6.x

  • Restart the settingsd Service:
    After configuring unique scratch paths for each host, restart the settingsd service to ensure it can access its configuration database correctly.

    #/etc/init.d/settingsd restart
  • Re-enable vSphere HA:
    Re-enable vSphere HA on the cluster to restore HA functionality.