When enabling/disabling the logging for the NAT, Firewall and VPN no change is made in NSX-T
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When enabling/disabling the logging for the NAT, Firewall and VPN no change is made in NSX-T

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Article ID: 382832

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Updated On: 05-20-2025

Products

VMware Cloud Director

Issue/Introduction

When enabling/disabling or updating the logging in the NAT, Firewall and VPN , the task succeeded in VMware Cloud Director (VCD) and no change is made in NSX-T.. editing the NAT/Firewall/VPN rule again will show the toggle for logging is not updated. 

 

Environment

VMware Cloud Director 10.x

Cause

This is a known issue impacting Cloud Director 10.5.x UI. This issue has been resolved in 10.6.x

in 10.6.x, users will now see the error: " Cannot configure system logging, missing right: Organization vDC Gateway: Configure System Logging"

Resolution

The user will need the permission: "Configure System Logging"  in order to update the logging option. ensure this is pushed from the default rights bundle.