VSE shut down abruptly. VSE.log file has shown the below error:
FATAL com.itko.lisa.coordinator.VirtualServiceEnvironmentImpl - Unexpected exception during startup.
java.lang.OutOfMemoryError: unable to create new native thread
at java.lang.Thread.start0(Native Method)
at java.lang.Thread.start(Unknown Source)
at java.util.Timer.<init>(Unknown Source)
at com.itko.lisa.coordinator.CoordinatorImpl.startTest(CoordinatorImpl.java:594)
at com.itko.lisa.coordinator.VirtualServiceCoordinator.startTest(VirtualServiceCoordinator.java:658)
at com.itko.lisa.coordinator.VirtualServiceImpl.start(VirtualServiceImpl.java:1037)
at com.itko.lisa.coordinator.VirtualServiceEnvironmentImpl.startTheService(VirtualServiceEnvironmentImpl.java:1497)
at com.itko.lisa.coordinator.VirtualServiceEnvironmentImpl.loadInitialServices(VirtualServiceEnvironmentImpl.java:550)
at com.itko.lisa.coordinator.VirtualServiceEnvironmentImpl.main(VirtualServiceEnvironmentImpl.java:347)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at com.exe4j.runtime.LauncherEngine.launch(Unknown Source)
at com.install4j.runtime.launcher.Launcher.main(Unknown Source)
Environment:
DevTest VSE
Cause:
VSE has run Out of Memory. The memory allocation to this application is not sufficient for the kind of load it is handling at the moment.
Resolution:
Increase the memory by -Xms and -Xmx values in the VSE’s vmoptions file i.e. VirtualServiceEnvironment.vmoptions [Or VirtualServiceEnvironmentService.vmoptions if running the VSE as a service].
Example of such setting in the vmoptions file is [Ensure there are given in two different lines]:
-Xms512m
-Xmx1048m
Additional Information:
CA Support is unable to define the exact required memory setting for these properties as this is environment and load specific. This value depends on the load and hardware settings in an environment. You will have to use a trial and error method to set the right memory setting that suits your load.
For any assistance on Performance engineering, Please contact your Account Manager who will put you in touch with CA Services.
Performance tuning is not in the scope of CA support team.