Site Recovery Plugin not showing up or erroring in vSphere Client after deployment
search cancel

Site Recovery Plugin not showing up or erroring in vSphere Client after deployment

book

Article ID: 382717

calendar_today

Updated On:

Products

VMware Live Recovery VMware vCenter Server

Issue/Introduction

Symptoms:

  • Registration of the SRM with vCenter completes successfully but Site Recovery UI does not load-up correctly in vSphere Client.

  • Under vcenter server recent tasks, below error will be seen indicating plugin download failures.

     

    "Cannot complete the operation. See the event logs for details. Error downloading plug-in. URL is unreachable. status coe:503, reason phrase. Service Unavailable"

  • In vCenter's logs /storage/log/vmware/vsphere-ui/logs/vsphere_client_virgo.log, we see the plugin fails to download.

    [2024-11-25T16:32:56.098+13:00] [ERROR] sdk-plugin-deployer-125       com.vmware.vise.plugin.status.RemotePluginStatusServiceImpl       DOWNLOAD_FAILED: Error downloading plugin package com.vmware.drui.plugin:9.0.2.24170200 from https://SRM-FQDN.com:443/drplugin/plugin.json.zip. Reason: URL is unreachable. Make sure that the URL is reachable. com.vmware.vise.plugin.download.PluginDownloadException: org.apache.http.client.HttpResponseException: status code: 503, reason phrase: Service Unavailable
            at com.vmware.vise.plugin.download.PluginDownloadServiceImpl.download(PluginDownloadServiceImpl.java:188)
            at com.vmware.vise.plugin.async.task.PluginDownloadTask.run(PluginDownloadTask.java:51)
            at java.util.concurrent.CompletableFuture$AsyncRun.run(CompletableFuture.java:1640)
            at com.vmware.vise.util.concurrent.QueuingCachedThreadPool$2.call(QueuingCachedThreadPool.java:873)
            at java.util.concurrent.FutureTask.run(FutureTask.java:266)
            at com.vmware.vise.util.concurrent.QueuingCachedThreadPool$QueueProcessor.run(QueuingCachedThreadPool.java:1271)
            at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511)
            at java.util.concurrent.FutureTask.run(FutureTask.java:266)
            at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149)
            at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624)
            at com.vmware.vise.util.concurrent.WorkerThreadFactory$1.run(WorkerThreadFactory.java:64)
            at java.lang.Thread.run(Thread.java:750)
    Caused by: org.apache.http.client.HttpResponseException: status code: 503, reason phrase: Service Unavailable
            at org.apache.http.impl.client.AbstractResponseHandler.handleResponse(AbstractResponseHandler.java:70)
            at org.apache.http.impl.client.CloseableHttpClient.execute(CloseableHttpClient.java:223)
            at org.apache.http.impl.client.CloseableHttpClient.execute(CloseableHttpClient.java:165)
            at com.vmware.vise.plugin.download.PluginDownloadServiceImpl.downloadPackageInfo(PluginDownloadServiceImpl.java:305)
            at com.vmware.vise.plugin.download.PluginDownloadServiceImpl.download(PluginDownloadServiceImpl.java:165)
            ... 11 common frames omitted
  • Manual download of Site Recovery Plugin in vCenter shell/SSH using wget fails with 403 forbidden error.The command would look like this:

    wget --no-check-certificate https://SRM-FQDN/drplugin/plugin.json.zip

Environment

Site Recovery Manager 8.x
VMware Live Site Recovery 8.x
VMware Live Site Recovery 9.x
VMware vCenter Server 8.x

Cause

  • vCenter fails to download the plugin due to incorrect proxy settings (if any involved).

  • Site Recovery Plugin download would fail even if there is network disconnection due to some other reason like no connectivity between SRM and VR, port issues, any physical networking changes or virtual switch configuration changes.

  • The Site Recovery certificate CN does not match the appliance hostname

Resolution

  • Set the correct proxy settings in vCenter Appliance Management.

  • Ensure the connectivity between vCenter and SRM is good. Both are reachable to each-other over port 443.

  • Change the Site Recovery certificate in the SRM Appliance VAMI, to match the hostname. 

  • Once connectivity is established, try download the plugin from vCenter using wget command to ensure the download is working.

  • If download is working, log in vCenter VM and restart the vsphere client service :

    service-control --stop vsphere-ui && service-control --start vsphere-ui

  • Observe vCenter /storage/log/vmware/vsphere-ui/logs/vsphere_client_virgo.log for drplugin download being successful